ActiveSync device not receiving new emails unless outlook is open

Have you noticed that your ActiveSync device (iPhone, iPad, Blackberry, Windows Mobile, Android phone, or any other device that use ActiveSync) does not receive new email messages from your Exchange server unless Outlook, or Outlook Web Access (OWA) is open?

This can sometimes be caused by the way antivirus software scans new emails. Some anti virus programs only scan new emails when they are accessed (either via Outlook, or OWA, but not by ActiveSync). The problem with this, is that the emails don’t get delivered to the user until they have been scanned. The easiest way to determine if this is the problem, is to open outlook, and see if you get emails straight away on your ActiveSync/mobile device. Then close outlook, and see if you still get new emails come in straight away. You might need to send a test email from another PC or different email provider to test this.

Thankfully there is an easy solution to fix this. A simple registry key change on the exchange server should fix this behavior. The setting is called Proactive Scanning. By default this setting is “0″, or off. Setting this setting to “1″, or on, means that all emails will be scanned as soon as they are received, instead of only on access. The second benefit of enabling proactive scanning, is that there may be an increase in speed when initially accessing new emails, as the server won’t have to scan it when you actually go to access it.

More details on proactive scanning can be found on the Microsoft website at the following address:

http://technet.microsoft.com/en-us/library/cc483040.aspx

The following steps detail how to enable proactive scanning:

  • Open the registry editor.
  • Browse through to HKEY_LOCAL_MACHINESYSTEMCurrentControlSetservicesMSExchangeISVirusScan
  • You should see the registry keys as per the image below.

  • Double click the “ProactiveScanning” key on the right. This will bring up the edit dialog.

  • Change the value from “0″ to “1″, and hit the “OK” button.

  • The Proactive Scanning setting is now enabled, but it will not take effect until you restart the exchange services, or you set the ReloadNow key to “1″.
  • The ReloadNow key should generally always appear as “0″, as after it is changed to “1″, and the config is reloaded, it will automatically get reset back to “0″.

  • Double click the ReloadNow key to bring up the edit dialog.

  • Set the value to be “1″, and press the “OK” button.

  • The key should now appear with a value of “1″, or enabled.

Press the F5 key to refresh the registry, or go to the View -> Refresh menu option. If Exchange is currently running, it should have picked up the registry change, reloaded the config settings, and set the ReloadNow key back to “0″.

  • The value should now appear as “0″ as per the image below.

The last thing to do is to test the iPhone/mobile/ActiveSync device, to make sure this has fixed the issue.

You should now receive emails as they come into the Exchange server, without any delays.


Leave a Reply